MX Trax
Results 1 to 6 of 6

Thread: Thumpstar Stator Wiring

  1. #1

    Default

    Hi

    Can anybody help with the thumpstar 110cc stator wiring? I have just swapped the engine in my bike to a thumpstar engine and I am having a few charging problems. The first rectifier I had was delivering between 7-50 volts , so I figured it probably wasn't regulating and purchased a new rectifier/regulator from monkeybike co uk, this regulator / rectifier supplies between 2 and 6 volts which isn't enough to keep the battery charged. I can only think that the wires coming from the engine are different colours than my original ones. There are 5 wires coming from the engine, 1 Ground (Green) then two to the rectifier (yellow and pink) and 2 to the cdi unit, does anybody know if this is correct? The bike runs okay, just can't seem to get the 12volts out to charge the battery.

    Thanks

    Matt

  2. #2
    Hotshot Baggy's Avatar
    Join Date
    Nov 2004
    Posts
    6,321

    Default

    Take the battery, starter motor etc. off. Problem solved!!

  3. #3

    Default

    Yer, I was actually looking at fixing it rather than bodging a fix, I would quite like to put some lights on, I suppose I could use cycle lights, but I thought I might try and use the battery available to me.

  4. #4
    Moderator Rupx.'s Avatar
    Join Date
    Jan 2005
    Posts
    19,519

    Default

    Try this, isnt not from a Thumpstar but will probaly help you, and if you want to fit lights

  5. #5

    Default

    Thanks for the diagram, I'm pritty sure I have 5 wires comming from the stator, but I'll double check what I have going to where tonight.

    Thanks

  6. #6
    Moderator Rupx.'s Avatar
    Join Date
    Jan 2005
    Posts
    19,519

    Default

    If you want it bigger say and i'll email you the big version

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •